Supporterede PHP-versioner

Hos Powerhosting tilbyder vi i skrivende stund muligheden for, at vælge imellem 6 PHP-versioner:

PHP 5.6
PHP 7.0
PHP 7.1
PHP 7.2
PHP 7.3
PHP 7.4

– Se mere om hvordan der let skiftes imellem versioner med phcli.

Vi anbefaler selvfølgelig altid, at man benytter nyeste mulige PHP-version. Dog kan den software man benytter ofte have begrænsninger – specielt hvis den pågældende software ikke holdes opdateret.

Vi sikkerhedspatchede igår(1 Juli, 2020) alle Magentoer i vores netværk, som ikke på forhånd havde fravalgt patching med en række patches. Vi ser desværre stadig en stor andel af ældre Magentoer og må igen på det kraftigste anbefale, at holde alt software opdateret. Ældre Magentoer op til version 1.9.2.x er afhængige af PHP 5.6 og vi holder derfor denne version kørende til trods for PHP 5.6 til og med PHP 7.1 pt. er End Of Life! Dette betyder at der til de nævnte PHP-versioner ikke udgives sikkerhedsopdateringer længere og brugen af dem er derfor på eget ansvar.

Herover ses en matrix over supporterede PHP-versioner påført udløbsdatoer. Se evt. nyeste version på php.net.

Til de kunder som kører Magento 1.9.2.x eller nyere tilføjede vi igår også Magentos officielle patch med PHP-kompatibilitetsrettelser. Dette gør Magento 1.9.2.x og nyere kompatibel med PHP 7.2 og vi anbefaler alle med disse versioner om at opdatere PHP-versionen hurtigst muligt. Er der spørgsmål til proceduren kan vi, som altid kontaktes på support@powerhosting.dk. Ifm. opdatering af PHP-versionen er det vigtigt, at gennemfå alle 3. parts moduler for PHP 7.2 kompatibilitet. Det er der selvfølgelig noget arbejde forbundet med, men til gengæld er der, udover sikkerheden, meget store performance forbedringer ved at skifte til PHP 7.2. Vi ser ofte en halvering af loadtime på sidevisninger.

Om forfatter

Relaterede artikler

Nyhedsbrev... Privat, sikkert og spam-fri.